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Summary
HAWS (The HIV Algorithm Workflow System) is an application for managing
the workflow and data capture processes associated with HIV studies.
HAWS walks the user through a series of steps for a patient visit, collecting
assay results from the user, managing requests for specimen redraws, and
ultimately determining the final result of the testing work for the patient visit.
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Getting started with HAWS
This section will get you acquainted with HAWS.

What is HAWS?
HAWS (The HIV Algorithm Workflow System) is an application for managing
the workflow and data capture processes associated with HIV studies.
HAWS walks the user through a series of steps for a patient visit, collecting
assay results from the user, managing requests for specimen redraws, and
ultimately determining the final result of the testing work for the patient visit.
HAWS works by assigning algorithms to patient visits. Each algorithm
determines what specimens need to be tested and what assays need to be
run for the visit. Depending on the results of each assay, the algorithm may
assign additional assays to be run. In this way, HAWS acts like a flow chart,
guiding the user from a visit to a final result, helping them keep track of
individual results and the next step needed in the process.
HAWS also includes many other tools useful for completing HIV testing work,
such as the ability to generate final reports for several patient visits at once,
print listings of specimens to be tested along with their storage locations, and
the ability to interact with data stored in LDMS.

What are algorithms and workflows
An algorithm is the logic for processing a patient visit; a workflow is a visit
that is currently being processed by an algorithm.
Algorithms are defined by network leadership and implemented in HAWS by
Frontier Science. Users cannot create new algorithms, nor can they modify
existing algorithms. An algorithm may define such things as what assays need
to be run for certain specimen types. For example, if a visit included a blood
specimen, the algorithm would define what assay(s) needs to be run for that
specimen. Depending on the results of the assay, the algorithm may define
additional tests. This might happen, for example, if a specimen tested positive
and a second test is needed to confirm the positive result.
A workflow is an instance of an algorithm. When a user selects a visit to
process in HAWS, they select the algorithm to use and the workflow is
created. Thus you can create several workflows using the same algorithm.
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Figure 1: Example algorithm and workflows based on it

An example algorithm (left) and workflows for patient visits using the logic from the algorithm (right).

While a workflow is active, HAWS will guide you to the text step in the
algorithm's logic automatically. Using the example, if a workflow orders a test
and the result is a positive, HAWS will automatically determine if this was the
first positive for the workflow and, if yes, automatically reassign the assay to
be run again.

LDMS and HAWS
HAWS is able to pull visit and patient information from your LDMS database.
To do this, HAWS will need access to the computer that is acting as your
LDMS server. The sync to the LDMS database is configured by User Support
upon installation.
Typically data from LDMS is populated in HAWS automatically and the process
will be transparent. If you do need to refresh data from LDMS manually, click
Tools > Refresh from LDMS from the HAWS menu bar.

Getting HAWS
HAWS will typically be installed by HAWS User Support. This is usually done
using a remote connection to your computer. Not only will HAWS User Support
install HAWS, they will also perform general configuration for you so that your
laboratory can start using HAWS right away.
HAWS User Support will ask you for specific information about your
laboratory, such as contact information and where you want files stored on
your server. This information will be used to initially configure HAWS. Most
of these settings can be updated later by your laboratory. A backup of the
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database should occur prior to the upgrade to a new version or the re-install
of the database.

Getting help
HAWS User Support is available 24 hours per day, 7 days per week.
HAWS User Support can answer questions about using HAWS and, if
needed, connect remotely to your computer to assist with technical issues.
Additionally, a link to the user manual can be accessed from the Help menu.
HAWS User
Support by
telephone

+1 716 834 0900 extension 7311

HAWS User
Support by
email

haws@fstrf.org

More information and support resources are available on the LDMS website.

Supported assays
The following assays and kits are supported by HAWS.
Assays

Supported kits

Abbott Prism

Abbott Prism, Anti HIV-1/2

Bio-Rad Geenius HIV 1/2 Confirmation Assay

Bio-Rad Geenius HIV 1/2 Confirmation
Assay

Alere

Alere Determine HIV-1/2 Ag/Ab Combo
Alere HIV Combo
Determine HIV Early Detect

DNA PCR

Roche Amplicor HIV-1
Roche COBAS AmpliPrep/TaqMan HIV-1
Qualitative

Enzyme Immuno Assay

Abbott Architect HIV Ag/Ab Combo
Abbott Axsym HIV Ag/Ab Combo
Abbott HIV-1/HIV-2 (rDNA)
Abbott Murex HIV-1.2.O
bioMerieux Vironostika HIV Ag/Ab HIV 1/2
bioMerieux Vironostika HIV Uni-Form II +
O
Bio-Rad Genetic Systems HIV 1/2 Plus O
Bio-Rad Genetic Systems rLAV
Bio-Rad GenScreen HIV 1/2
Bio-Rad Genscreen Ultra HIV Ag-Ab HIV
1/2
Bio-Rad GS HIV Combo Ag/Ab EIA
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Assays

Supported kits

HIV-1 Total Nucleic Acid Assay

HIV-1 Total Nucleic Acid Assay

Multi-Spot Assay

Bio-Rad Multispot HIV-1/HIV-2 Rapid Test

OraQuick

OraQuick Rapid HIV-1 Antibody Test

RNA PCR

Abbott m200 RealTime PCR HIV-1
Roche Amplicor Monitor HIV-1 Standard
Ver 1.5
Roche Amplicor Monitor HIV-1
Ultrasensitive Ver 1.5
Roche COBAS Amplicor Monitor HIV-1
Standard Ver 1.5, with COBAS AmpliPrep
Roche COBAS Amplicor Monitor HIV-1
Ultrasensitive Ver 1.5, with COBAS
AmpliPrep
Roche COBAS AmpliPrep/COBAS Taqman
HIV-1, Version 1.0
Roche COBAS AmpliPrep/COBAS Taqman
HIV-1, Version 2.0
UW Developed HIV-1 RNA Real-Time
RTPCR

SD Bioline

SD Bioline HIV-1/2 3.0

Western Blot Bio-Rad Genetic Systems HIV-1

Bio-Rad Genetic Systems HIV-1

Western Blot Bio-Rad New Lav Blot II

Bio-Rad New Lav Blot II

Related tasks
Creating a new run on page 32

Configuring HAWS
This section will describe the various configuration options and features
available in HAWS.

User management in HAWS
HAWS is user-based. In order to use HAWS, you must login using your own
unique user account. Your user account determines what you are permitted to
do in HAWS, and HAWS tracks what user completes certain actions.
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Figure 2: The User Administration window

(1) existing users, (2) information for currently selected user, (3) permissions for currently selected user, (4) create a
new user

There are three types of permissions that users can have in HAWS:
Administrator

An administrator can make changes to other user
accounts, create and inactivate users, and change
configuration settings in HAWS. The only setting that
administrators cannot change is their own status as an
administrator. This prevents users from accidentally
removing all administrators.

Can approve
results

Users with this permission can complete the result
algorithm task and approve assay results.

Can view and
print reports

Users with this permission can generate final reports for
workflows.

Note: Administrators don't inherently have the ability to approve
results and generate reports; these are separate concepts in HAWS.
HAWS User Support will typically create the necessary users for you when
installing HAWS. If no users were created for you, the default user is admin
with the password admin. To prevent users from logging in as the admin
account to complete normal work, the admin account should be set to inactive
once you have created at least one other system administrator.

Creating new users
Prerequisites
Note: Creating, removing, and modifying other user accounts requires
system administrator permissions. Non-system administrators can only
modify certain properties for their own user account.
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Steps
1.

Click Tools > User Administration from the HAWS menu bar.

2.
3.

Click the New user button.
Enter the new user's user name into the User name text box.
The user name is not case sensitive. The user name must also be
unique among all users, including those that have already been
deleted.
Enter the new user's full name into the Full name text box.
Enter the new user's initials into the Initials text box.
Select any permissions that should be assigned to the user.

4.
5.
6.

Option
system administrator

Can create, modify, and remove
other users

Can approve results

User can approve assay results
and complete the result algorithm
task

Can view and print reports

User can complete the final report
task and print bulk reports

Result
New users will have the same password as their user name by default. For
example, a user with the user name ROBERT will have the default password
robert (lower case).
After you are finished
The new user should change his or her password after logging in for the first
time. This is done by selecting Tools > User administration from the HAWS
menu bar, and then clicking the Change password button.

Modifying users
Steps
1.
2.
3.

Click Tools > User Administration from the HAWS menu bar.
Select the user to modify from the list of users on the left.
Modify user information as needed.
• Regular users can only change their user name, full name, and
password
• Administrators can change user permissions
• Administrators can inactivate the selected users. Inactive users
cannot log on to HAWS, but will still be available for selection in
drop-down lists (e.g. selecting the technician for an assay run)
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4.

Note: While it is possible to delete users, it is recommended
that users be inactivated in case the user's account is needed
in the future.
After all changes are made, click the Save button.

Options window
The Options window allows the user to configure several general HAWS
settings. The Options window is accessed by clicking Tools > Options from
the HAWS menu bar.
Note: During installation, HAWS User Support will have configured
these settings for you.
Figure 3: The Options window
(1) location where exports will be generated, (2) location where final workflow reports will be generated, (3) location
for HAWS log files, (4) location where backup files will be generated

The following settings can be changed in the Options window:
Export base
folder

This is the directory where SCHARP export files and
adjudication export files will be saved. Files will be placed
in sub-directories in the export base folder.

Reports base
folder

This is the directory where workflow reports will be
saved.

HAWS data
folder

This is the location where log files generated by HAWS
will be stored.
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Search for
samples not in
storage

If enabled, samples that have not been stored in the
LDMS Storage task will be displayed.

Automatically
lock HAWS if
idle

This is the amount of time (in minutes) after which
HAWS will automatically lock and require a user name
and password. To disable this feature, set this number to
0

Backup settings This is the directory on the HAWS server where
automatically generated backup files of HAWS data will
be created, as well as the number of days the backup
files will be retained. The oldest files will be deleted after
the set retention days (default: 7 days).
Note: Because the HAWS backup files are stored on the HAWS server,
it is important that you manually copy these files to a safe location that
is not on the HAWS server. It is recommended that you do this once per
week.
Related concepts
Backup management on page 22
Related tasks
Export reports on page 56
Export reports are tab-delimited text files that are intended to be sent to
SCHARP.
Creating unblinded EOS reports on page 55
Batch printing final reports on page 54

Protocol Administration
Note: Only users with system administrator privileges can access
Protocol Administration.
The Protocol Administration window is used to manage what protocols and
patients are blinded and unblinded. Protocol administration is accessed by
clicking Tools > Protocol Administration from the HAWS menu bar.
Figure 4: The Protocol Administration window
(1) add/view/modify protocols, (2) add/view/modify unblinded patients, (3) add new protocol to HAWS, (4) modify
selected protocol, (5) list of protocols entered into HAWS
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For the evaluation of sero-reactivity (EOS) and post-study (POS) algorithms,
the final workflow report can be generated as either blinded or unblinded.
Here is how the two versions differ:
• A blinded report shows the overall final workflow result, but does not
include individual test results.
• An unblinded report shows both the final workflow result and individual test
results.
The routine (VST) and recent exposure (EXP) algorithms always produce
blinded reports. The infected testing (INF) algorithm essentially produces an
unblinded report because it is a report of an individual RNA PCR test.
To determine whether an HIV Infection Status Report should be produced
as blinded or unblinded, HAWS checks whether the entire protocol has been
unblinded. If the entire protocol has not been unblinded, HAWS will check
if the specific Patient ID for this algorithm has been unblinded. If neither of
these are the case, then HAWS will produce a blinded report.

Changing protocol adjudication settings
Steps
1.
2.
3.

4.
5.

On the Tools menu, click Protocol Administration.
Select the study to be modified, and then click Edit.
Modify the Requires adjudication and Allows optional adjudication
settings as needed.
Requires
adjudication

Users will not be able to approve a final result for
a workflow until an adjudication report has been
generated and a diagnosis date has been set.

Allows
optional
adjudication

Users will be able to generate an adjudication
report at any time during the workflow, and may
optionally set a diagnosis date.

Click OK.
In the Protocol Administration window, click Close.
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Related tasks
Generating adjudication report on page 56

Unblinding a protocol
Prerequisites
Note: To access the Protocol Administration window, you must have
system administrator privileges.
Steps
1.
2.

On the Tools menu, click Protocol Administration.
On the Protocols tab, click Add.
The Edit Protocol Information window will open.

3.
4.
5.
6.

In the Protocol box, enter the protocol number to be unblinded.
In the Unblinded date box, enter or select the date that the protocol
was un-blinded.
Optional: If you want to exclude any new data generated for this
protocol from SCHARP export files, select the Locked option.
Click OK.

Result
After completing these steps, the unblinded study will be added to the list
on the Protocols tab in the Protocol Administration window. It can be
modified by selecting it and clicking the Edit button. It can be removed by
selecting it and clicking the Delete button.
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Unblinding patients
Prerequisites
Note: To access the Protocol Administration window, you must have
system administrator privileges. You must also have patient information
file provided by SCHARP.
Steps
1.
2.
3.
4.

5.

On the Tools menu, click Protocol Administration.
Select the Patients tab.
Click the Open file button.
Select the patient information file provided by SCHARP.
The list of patients to be unblinded from the file will appear in the list
on the Patients tab. This list should be reviewed for accuracy before
continuing with the unblinding.
Click the Unblind selected patients button.

Configuring the test now storage location
Prerequisites
Note: You will need system administrator privileges to access the
Storage Administration window.
Background
A test now location is a location in the LDMS storage task associated with
an assay in HAWS. If you create a workflow for a visit in HAWS and that
visit has specimens in the test now location in LDMS, those specimens will
automatically be assigned to an assay, allowing you to bypass the select
sample task.
Steps
1.

Click Tools > Storage Administration from the HAWS menu bar.
The Storage Administration window will open.
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Figure 5: The Storage Administration window

(1) assay to be assigned, (2) from left to right: primary type, additive, derivative, sub additive/derivative,
(3) from left to right: LDMS freezer, level, sub-level, and container, (4) create new test now location, (5)
modify selected test now location, (6) remove selected test now location

2.

Click the Add button.
The Edit Test Now Location window will open.
Figure 6: The Edit Test Now Location window

(1) assay to be assigned, (2) type of specimens to be assigned assay, (3) LDMS storage location

3.
4.

Select the assay to be automatically assigned to specimens in this
storage location from the Assay list.
In the Derivative box, specify the LDMS derivative code of specimens
to be assigned to selected assay.
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Note: While the derivative is required, the specimen type
information is not currently used by HAWS.
5.

Required: Specify the exact name of the freezer to be assigned the
selected assay.

6.

Specify the Rack, Sub-rack and Box.

7.

• If you want a specific storage location, you can specify it by name.
• If you want to select all sub-levels (for example, all racks in a
freezer), enter * into the text box. This is used to specify all
racks, sub-racks, and boxes in the VTN AB freezer as this test now
location.
Click the OK button.

1

2

Result
The new test now location will be created and added to the "Test Now"
locations list. To modify a test now location after it has been created, select
it from the "Test Now" locations list, and then click the Edit button. To
remove a test now location, select it, and then click the Delete button.
Note: Deleting a test now location means that specimens in the
storage location will no longer automatically be assigned an assay. The
storage location in LDMS will not be modified or removed.
Related information
http://www.ldms.org/resources/ldms/codes/

Location administration
The Location Administration window has two purposes:
• Set the contact information for your laboratory.
• View and modify clinics that have been manually added by your laboratory
to HAWS or clinics that have been loaded from LDMS.
Note: For clinics that are loaded from LDMS, the LDMS clinic ID
cannot be edited.

1
2

A rack and sub-rack are known as levels and sub-levels in LDMS.
A box is known as a container in LDMS.
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Figure 7: The Location Administration window

(1) clinics already added to HAWS, (2) information for selected clinic or entry fields to add new location, (3) create
new clinic, (4) save changes to selected clinic or save new clinic, (5) remove selected clinic, (6) view and edit address
of current lab

Your laboratory's contact information as specified in will be printed at the top
of final workflow reports generated by your laboratory.
To access Location Administration, click Tools > Location
Administration from the HAWS menu bar. A location can by modified by
selecting it from the Clinics list on the left, modifying its information on the
right side of the window, and then clicking the Save changes button. If the
location is an LDMS clinic, you will not be able to modify the LDMS clinic ID
text box for the clinic.

Holiday administration
The Holiday Administration window allows you to specify given days
during the calendar year that are considered holidays at your laboratory. This
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ensures that days that your laboratory is not operating will be subtracted from
the calculations in the Turn Around Time reports.
Note: HAWS does not automatically add any holidays.
Figure 8: The Holiday Administration window

(1) select year to add/view holidays, (2) select day for new holiday, (3) enter name for new holiday, (4) add selected
date and name as new holiday, (5) holidays already added for the selected year, (6) save changes to current year

Access the Holiday Administration window by clicking Tools > Holiday
Administration from the HAWS menu bar.
To add a holiday:
1.
2.
3.
4.
5.

Select a year from the Year list.
Select a date from the calendar control.
Enter a name for the holiday into the Holiday Description text box.
Click the Add button.
Click the Save Year button
Note: HAWS does not allow annual or recurring holidays. If a holiday
occurs every year, you will need to add it each year.

Default algorithm setup
Setting up custom default algorithms for various Study/VID combinations can
save you a lot of time, and give you additional flexibility.
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Steps
1.

From the Tools menu, click Default algorithms.

2.
3.
4.

Click Add.
Enter the visit unit you wish to set a default algorithm for.
Set Study to the desired study.
Note: Specifying a Study value allows for the ability to,
for the same visit type, use Algorithm A for one study and
Algorithm B for another study. Alternatively, you can leave
Study blank which will allow the algorithm assignment to be
applied to all studies without a specific algorithm assignment.

•

Figure 9: The Default Algorithms Window

Default assay kit assignment
A default assay kit allows you to define the kit that can be used for a specific
assay on a specific algorithm
If an algorithm has a kit assignment, workflows using that algorithm will limit
the defined assay to using the selected kit. If that kit is not selected for the
assay, the specimens will not be available to add to the run.
Example default kit assignment
If you set the following kit assignment, specimens assigned the EIA 1 assay
on workflows using the routine algorithm will only be displayed if the Bio-Rad
1/2+O kit is selected. If another kit for the assay is selected, the specimens
will not be available to add to the assay run.
Algorithm

Assay

Kit

Vaccine Routine

EIA 1

Bio-Rad Genetic
Systems HIV 1/2 Plus
O
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Adding kit assignments
Add an assay kit default to restrict kit selection available for individual
algorithms and assays.
Steps
1.
2.
3.

On the Tools menu, click Kit assignment.
Click Add.
Enter the following information.
• In the Algorithm box, select the algorithm to which this default
should be applied.
• In the For tests starting with box, select an assay.
• In the Default kit box, select the kit you want to use.
• In the Study box, select the study you want to use.
Note: Specifying a Study value allows for the ability to,
for the same algorithm type and test type, use test A for
one study, test B for another study. Alternatively, you can
leave the Study box blank as a wildcard option which will
allow which will allow the kit assignments to be applied to all
studies without a specific kit assignment.

4.

Click OK.

Modify kit assignment
You can modify the kit of an existing kit assignment.
Steps
1.
2.
3.
4.

On the Tools menu, click Kit assignment.
Click the kit assignment you want to change.
Click Edit.
In the Default kit box, change the kit assigned.

5.

Note: Only the kit can be changed. If you need to change the
algorithm or assay, delete the kit assignment and create a new
one instead.
Click OK.

Delete kit assignment
You can remove an existing kit assignment.
Steps
1.
2.
3.
4.

On the Tools menu, click Kit assignment.
Click the kit assignment you want to delete.
Click Delete.
When you see the “Are you sure you want to permanently delete the
default kit assignment” message, click Yes.
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Backup management
HAWS will automatically check if a backup of its internal database has been
created for the current date every time you start or exit HAWS. If a backup
was not created, one will be created automatically. The HAWS server installer
includes a warning text reminding the user to backup HAWS databases before
running the installer.
Backup files will be stored in the backup location on the HAWS server. One
day’s backup per file is saved and, by default, seven consecutive days are
saved in the backup directory. Each day, the oldest will be removed as a
newer one is created. Both the backup location and the number of days
backups will be retained can be changed in the Options window.
Figure 10: The Backup window

Important: The HAWS backup location is typically on the same
computer where HAWS is installed. This means that if something
happens to the computer, the backup files will be lost. It is important to
regularly copy automatic backups to a safe location, such as a CD-RW.
Users with system administrator privileges can manually create a backup file.
To manually create a backup file:
1. Click Tools > Backup from the HAWS menu bar.
2. Click the Backup button.
Related concepts
Options window on page 11

Steps for Verifying a Backup File
To verify a backup file, perform the following steps:
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1. Verify that the file name is as expected, in the format
"HAWS_Backup_ID_YYYYMMDD.bak (where "ID" is the two letter lab
code).
2. Verify that the file's date of creation is as expected.
3. Verify that the file size is greater or equal to that of the previous backup
file.

Tasks
HAWS works by creating tasks that represent each step for the visit in the
algorithm.
Think of tasks as steps in the workflow. The tasks within workflows are shown
on the left in the Common Tasks list. All workflows start by assigning a visit
to the workflow (the Assign a patient visit to a workflow step), after which,
they move through the remaining tasks until they are completed.
Figure 11: Basic process for a workflow in HAWS

The basic process that a patient visit will go through, with the steps that occur in HAWS emphasized

Workflows will go through the following steps:
Assign a patient Select an algorithm for the visit, and create a new
visit to a
workflow for the visit using the algorithm
workflow
Select sample

Select specimens from the visit to be tested
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Process assay

Add the specimens selected for testing to an assay run or
create a new assay run

Submit redraw

Generate paperwork for submitting a request to have a
specimen for a visit redrawn

Receive redraw

Process a specimen that has been redrawn by selecting
the specimen from the new visit

Review assay

Review and approve the results from assay runs

Result
algorithm

Review all the assay results for the workflow and select a
final result for the workflow

Final report

Generate the final workflow report

There are other steps in the Common Tasks list that do not fall into the
sequential workflow for the steps listed above. Those non-sequential steps
are:
Manage runs

This step allows you to setup assay runs for different
assays. This task happens during the process assay task.
The reason it is separate from the sequential workflow
is because specimens from different workflows could be
tested on the same assay run.

View all
workflows

This step displays all workflows that are currently in
progress, and lists their current pending tasks. From
here, you can view overall details about the workflow,
close or cancel workflows, or perform the next task for
a workflow. Think of this as a home screen so you can
gauge the overall work that still needs to be completed in
HAWS.

Reassign
specimen for a
test

This step allows you to change the specimen that was
assigned to an assay after the select sample task has
been completed but before the process assay task has
been completed. You would need to do this if you wanted
to use a specimen other than the one automatically
selected by HAWS or if a manually selected specimen
was selected in error.

Assigning patient visits to an algorithm
Background
New workflows are created by assigning an algorithm to a patient visit. This is
done using the assign a patient visit to workflow task.
Steps
1.

Select the Assign a patient visit to a workflow link from the
Common Tasks list on the left.
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The Assign a patient visit to workflow window will appear.
Figure 12: The assign a patient visit to workflow task

(1) filters for visit search results, (2) search for visits meeting search criteria, (3) visits that meet search
criteria, (4) algorithm to use for newly created workflows, (5) create new workflow for selected visits, (6)
manually enter new patient or a visit for the selected patient

2.
3.
4.

5.

Select a group from the Group list.
Optional: Filter the search results by entering information into any of
the boxes in the Optional search filters section.
Optional: Select the Include already assigned visits option if you
want visits that have already been assigned to a workflow to appear in
the search results.
This may be necessary if you need to assign an additional workflow to
a visit. This might happen, for example, if a workflow for an incorrect
algorithm was created for a visit.
Click the Search button.
HAWS will display a list of available patient visits found in LDMS, or
patient visits that were manually created for the selected group. Rows
that are highlighted indicate visits that have already been assigned to
an algorithm or a visit with multiple specimen dates.

6.

If you do not see the patient or visit, you may need to enter it
manually.
Select one or more visits.
To select more than one visit, hold down the Ctrl or Shift keys while
selecting visits. To select all visits, click the Select all visits link
below the search results.
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7.

8.

Optional: Select an algorithm from the Algorithm to start list.
The default algorithm assigned by HAWS is determined by the visit
units and the protocols set up in the Default Algorithms screen. If the
visit unit is not one of the units listed, HAWS will not select a default
algorithm.
Click the Start workflow button to set the algorithm assignments.
You cannot click the Start workflow button if any patient visits do
not have an algorithm selected. This would only occur if a visit's visit
unit was not recognized.

Related tasks
Creating a new patient-visit on page 26
Entering a visit not in LDMS on page 27
Receive redraw task on page 44

Creating a new patient-visit
Background
Visits and patients are typically imported into HAWS from LDMS so that HAWS
users do not need to create them.
If a patient visit was not entered in LDMS, you can manually create the
patient, along with a visit, in HAWS so that a workflow can be created.
Steps
1.
2.
3.

Open the assign a patient visit to a workflow task.
Select a group from the Group list.
Click the New patient button.
The Create New Patient window will appear. This is where you will
enter the information for the patient and the patient's visit.
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Figure 13: The Create New Patient window

4.
5.

Enter the patient's information and the information for the patient's
initial visit.
Select the clinic where the visit occurred from the Clinic list.
If the clinic needed is not available in the clinic list, add it by doing the
following:
5.1. Click the Add clinic... button.
The Add Clinic window will appear.
5.2. Enter the information for the clinic.
5.3. Click the OK button.
The click with the information you specified will be added to the
Clinic list.
Note: Clinics that are manually added are only added to
your local HAWS database. They will not be available in
LDMS. If you need to have a clinic added to LDMS, contact
HAWS User Support for assistance.

Related tasks
Assigning patient visits to an algorithm on page 24

Entering a visit not in LDMS
Prerequisites
To create a visit, the patient must already exist. If the patient was not added
in LDMS, you can add it manually it HAWS.
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Background
If a visit for a patient was not entered in LDMS, you can manually create the
visit in HAWS so that it can be assigned a workflow.
Steps
1.
2.
3.

4.

5.
6.

Click the Assign a patient visit to a workflow link from the
Common Tasks list on the left.
Select a group from the Group list.
Optional: Filter the search results by entering information into any of
the boxes in the Optional search filters section.
The Patient ID, Study, and Visit unit fields allow for the use of
wildcard characters. An asterisk (*) represents one or more of any
character; an underscore (_) matches a single character.
Optional: Select the Include already assigned visits option if you
want visits that have already been assigned to a workflow to appear in
the search results.
Select a single patient visit.
This is a visit for the patient for which you want to add a new visit.
Click the New visit button.
The Create New Visit window will appear. This is where you will
enter the new visit information.

7.
8.

Complete the visit information.
Select the clinic where the visit occurred from the Clinic list.
If the clinic needed is not available in the clinic list, add it by doing the
following:
8.1. Click the Add clinic... button.
The Add Clinic window will appear.
8.2. Enter the information for the clinic.
8.3. Click the OK button.
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The click with the information you specified will be added to the
Clinic list.

9.

Note: Clinics that are manually added are only added to
your local HAWS database. They will not be available in
LDMS. If you need to have a clinic added to LDMS, contact
HAWS User Support for assistance.
Click the OK button.

Result
The new patient visit will automatically be assigned a default algorithm based
on its visit unit.
Related tasks
Assigning patient visits to an algorithm on page 24

Select sample task
Automatic sample selection
When a select sample task is assigned to a workflow, HAWS will try to
automatically select the appropriate specimen.
Using the information entered in the Storage Configuration module, HAWS
will look up the Test Now location appropriate to the assay type. If there is
one or more specimens available in the appropriate Test Now location(s) for
the patient visit, those specimens will be selected. If there is more than one
specimen available in the Test Now location, HAWS will use the specimen
stored at the highest numbered freezer, rack, box, etc.
If there are no specimens available in the Test Now location(s), and there is
only one specimen available in LDMS (in any storage location) for the patient
visit, HAWS will select that specimen.
If more than one specimen is available you must manually select the correct
specimen. If no specimens are available, you must add it in HAWS. Until a
specimen is selected, the select sample task will remain pending. Additionally,
it is possible to filter what samples are shown when selecting for a particular
visit to show specimens marked as never store or to only include specimens
from the same visit collection date.

Manually selecting samples
Background
If HAWS is not able to automatically select the correct specimen for a
workflow, you will need to select the specimen manually.
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Steps
1.
2.
3.

Click the select sample task from the Common Tasks list on the left.
The Available Tasks window will appear.
Select the task to which you want to manually add specimens.
Click the Do task button.
Figure 14: The Select Specimen window

4.

The Select Specimen window will appear. This is where you select
a specimen or add a new specimen. The specimens for the selected
patient and visit that are currently available in LDMS will be displayed.
Optional: To add a specimen, click the New specimen button.
Example
Figure 15: The Create New Specimen window

4.1. Required: Enter either a Global specimen ID or Other
specimen ID , or both.
4.2. Enter the Draw date/time for the specimen.
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5.

4.3. Optional: Enter a primary and additive for the specimen.
4.4. Required: Enter a Derivative type for the specimen.
4.5. Enter any other pertinent specimen information.
4.6. Click the OK button.
The Create New Specimen window appears and a new specimen is
added.
Select a specimen from the list.

Related tasks
Reassigning a specimen on page 31
Receive redraw task on page 44

Reassigning a specimen
Prerequisites
The workflow must be in the process assay task, and no results yet entered
for the specimen that is currently assigned.
You can reassign a specimen that already has a result to a task. If you do
this, the specimen's existing result will be used.
Background
After completing the select sample task, it may be necessary to change the
specimen was selected for a test. This may happen if you want to use a
specimen other than one automatically selected by HAWS or if a specimen
was selected in error.
Steps
1.
2.
3.
4.

In the Common Tasks list, click Reassign specimen for a test.
In the Pending Tests list, select the test to modify.
Click Change specimen.
Select a new specimen to be tested.

5.

• Specimens for the visit entered into LDMS or HAWS will be
displayed in the Specimens list.
• If the specimen is not present, it can be created by clicking the
New specimen button.
Click the OK button.

Result
The specimen assigned to the assay will be changed to the one you specified.
The workflow will remain in the process assay task until that task is
completed.
Related tasks
Manually selecting samples on page 29
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Assay run management
The manage runs task is used to view runs that have been set up for each
assay supported by HAWS. By default, only runs that have not yet been
completed are displayed. Previously completed runs can be displayed by
selecting the Show completed runs option.
Figure 16: The manage runs task

(1) selected assay, (2) selected kit for assay, (3) runs for the selected assay and kit, (4) change the specimens to
be tested on the selected run, (5) run the assay or approve results, (6) create new run for selected assay and kit, (7)
generate paperwork for selected run

The paperwork that can be printed for the assay run will vary, depending on
the type of assay and its current status. The Print specimen locator option
will be available for all assay runs.

Creating a new run
Steps
1.
2.
3.
4.
5.

6.

7.

Select the manage runs task from the Common Tasks list on the left.
Select an assay from the Assay list.
Select an assay kit from the Kit list.
The kit options available will vary, depending on the assay selected.
Click the New run... button.
The Setup Assay Run window will open.
Select the specimen(s) to be tested from the Available samples list.
The available samples are all specimens assigned to this assay across
all active workflows, except for algorithm-assay combinations with a
different defined assay kit. To select multiple specimens, press and
hold the Ctrl or Shift key.
Click the ⇩ button.
The selected specimen(s) will be moved to the Selected samples list
at the bottom of the window.
Click the Save run button.
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Result
The new assay run will be created and assigned a run ID. It will have the
initial status of pending.
Related reference
Supported assays on page 7
The following assays and kits are supported by HAWS.

Assay run reports
There are several useful reports that can be generated from the run
management task. These reports are available to the right of the Available
runs list.
Specimen
locator report

This report can be used to help locate specimens to
be retrieved for testing. The report includes specimen
identifiers such as the global specimen ID or other
specimen ID. If the specimen was added to storage in
LDMS, the report will also include the LDMS storage
location.

Run worksheet
report

This report can be generated for the Enzyme Immuno
Assay (EIA), Multi-Spot Assay, OraQuick Assay, and
theAlere Assay. This report can be used to assist in
manually recording and entering the results of an assay
run. It lists each test on the run, with blank spaces
provided for you to enter the results.

Completed
run worksheet
report

This report can only be generated for runs that have
already been entered. It can be used to assist in the
verification and approval of results for each test on the
run. It is similar to the Run Worksheet Report, except
that it includes the test results that were entered.

Running an assay
Steps
1.
2.
3.

4.
5.

Open the manage runs task.
Select an assay from the Assays list.
To display all pending assay, runs, select (Any) from the Assay list.
Select a kit from the Kit list.
To display runs for all kits for the selected assay, select (Any) from
the Kit list.
Select an assay run from the Available runs list.
If you do not see an assay run, you may need to create it.
Click the Enter/review results button.
The Assay Results window for the assay appears. This window
contains information about the run and specimens being tested. The
Samples list contains a listing of specimens being tested on the run.
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These specimens are in the same order as they would appear on the
Specimen Locator Report, Run Worksheet Report, and Completed Run
Worksheet Report.
Figure 17: The Assay Results window

(1) specimens being tested, (2) details for selected specimen, (3) final result for the assay run, (4) finalize
results for selected specimen, (5) approve committed results, (6) fields specific to the assay being run will
appear here, (7) save changes and close the window

The Samples list shows the following information:
Note: If you only see the specimen identifier for specimens
being tested, click View > Extra test info in assay results
from the HAWS menu bar.
specimen

This is the identifier for the specimen, such as the
global specimen ID

Patient ID

This is the patient identifier for the specimen

Wf ID

This is the workflow ID for the workflow to which
the specimen is assigned.

T

Indicates whether or not the specimen has been
tested. Y indicates that the specimen has been
tested; N indicates that the specimen has not been
tested.
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6.

7.
8.
9.

10.

11.

R

Indicates whether or not the specimen has had
its result committed in HAWS. Y indicates that the
specimen result has been committed; N indicates
that the specimen has not yet been tested.

A

Indicates whether or not the specimen's result has
been reviewed and approved. Y indicates that the
result has been approved; N indicates that the
specimen has not yet been approved.

Optional: To change the status of the run to Assigned, select the
Assigned to technician for testing option.
If you select this option, you can click the Close button to exit the
Assay Results window. The status of the assay run will be updated to
reflect that it has been assigned.
Select a specimen from the Samples list on the left.
Optional: If you do not want to include this test's results in the final
report for the workflow, select the Do not report option.
Optional: If you do not want to include this assay test's results in the
export file that is generated to be sent to SCHARP, select the Do not
export to SCHARP option.
Enter the assay results in the fields on the right.
The result fields will vary, depending on the assay you are running.
Refer to the appropriate section for the assay you are running for
more information.
After the results for each specimen have been entered, click the
Commit results button.
Committing results indicates that you are finished entering results for
the assay.
Important: Committing results immediately advances the
workflow to the review assay task if all tests for the current step
in the workflow are completed.
Note: If you attempt to modify results after they have been
committed, you will be prompted with a warning, but will still be
permitted to change the result. Runs that have been approved
cannot be modified unless they are de-approved.

12.

Click the Close button.
Changes made to the assay run will automatically be saved. If you
want to close the window without saving changes, select the X button
in the upper-right corner of the window.

Result
At this point, the assay has been run, however the results have not been
approved.
Related tasks
Export reports on page 56
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Export reports are tab-delimited text files that are intended to be sent to
SCHARP.

Available Results for Assay Types
Abbott Prism assay
The valid options for the specimen Final result are:
•
•
•
•
•
•

Reactive
Nonreactive
Equivocal
QNS
Invalid
Test Not Performed

Bio-Rad Geenius HIV 1/2 Confirmatory Assay
The valid options for the specimen Final result are:
•
•
•
•
•
•
•
•
•
•
•

HIV Negative
HIV-2 Indeterminate
HIV-1 Indeterminate
HIV Indeterminate
HIV-1 Positive
HIV-2 Positive
HIV-2 Positive (with HIV-1 Cross-reactivity)
HIV Positive Untypable
QNS
Invalid
Test Not Performed

Results can be entered for the following bands, with plus or minus available
for each band:
•
•
•
•
•
•
•

gp36
gp140
p31
gp160
p24
gp41
Ctrl

Results can be entered for HIV-1 Interpretation and HIV-2 Interpretation, and
the result options for those are the following:
• Reactive
• Non-reactive
Note: The field for the result option can be left blank.
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HAWS will only permit a test result to be committed or approved if none
of the bands are unspecified, unless the result is invalid, QNS, or test not
performed. HAWS will also calculate the expected result, and warn you if the
result selected does not match the expected result.
Alere assay
There are three result fields that must be completed for this assay:
• control
• HIV-1 p24 Ag
• HIV-1/2 Ab
For each band, select either reactive or non-reactive. These boxes must be
completed, unless the final result is QNS, Invalid, or Test Not Performed.
The valid options for the final test result are:
•
•
•
•
•
•
•

Non-reactive
Reactive for HIV Antibody
Reactive for HIV Antigen
Reactive for HIV Antibody and Antigen
QNS
Invalid
Test Not Performed

DNA PCR assay
The valid options for the final test result are:
•
•
•
•
•
•

Positive
Negative
Equivocal
QNS
Invalid
Test Not Performed

Enzyme Immuno Assay (EIA)
The following result fields are specific to the EIA assay:
Final result

HAWS will automatically complete this field for you
based on the OD/cutoff ratio. You can override the
automatically calculated result if needed. The following
options are available for the EIA final result:
• Reactive
• Non-reactive
• Equivocal (only available for the Bio-Rad GenScreen
HIV 1/2 and Bio-Rad Genscreen Ultra HIV Ag-Ab HIV
1/2 kits)
• QNS
• Invalid
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• Test Not Performed
Qualifier

This is the operand for the OD. By default, this field is set
to =. If the reader device detected an OD outside of its
range of quantitation, you would need to change this to
reflect the range.

OD

The OD result for the specimen. The default value is
blank. You must enter a non-negative number unless
the Final Result field is Invalid, QNS, or Test Not
Performed.

Cutoff

The cutoff result for the specimen. The default value is
blank. You must enter a non-negative number unless
the Final Result field is Invalid, QNS, or Test Not
Performed.

OD/cutoff ratio

This read-only value is automatically calculated based on
the OD and Cutoff that you entered for the specimen.

S/CO

This field is displayed instead of OD and cutoff for the
Abbott Architect HIV Ag/Ab Combo and Abbott Axsym
HIV Ag/Ab Combo kits. The default value is blank. You
must enter a non-negative number unless the Final
Result field is Invalid, QNS, or Test Not Performed.

HAWS will complete the Final result field for you using the logic described
below. You can override the result chosen by HAWS and select a different
result. If the ID/cutoff ratio is modified, HAWS may modify the Final result,
but will provide you with a message if it does.
For all EIA kits other than the Bio-Rad GenScreen HIV 1/2 and Bio-Rad
Genscreen Ultra HIV Ag-Ab HIV 1/2 kits, HAWS will suggest a final result
using the following logic:
• Ratio greater than or equal to 1.0 will be considered Reactive
• Ratio less than 1.0 will be considered Non-reactive
For the Bio-Rad GenScreen HIV 1/2 and Bio-Rad Genscreen Ultra HIV Ag-Ab
HIV 1/2 kits, the following logic applies:
• Ratio greater than or equal to 1.0 will be considered Reactive
• Ratio between 0.90 and 0.99, inclusive, will be considered Equivocal
• Ratio less than 0.90 will be considered Non-reactive
HIV-1 Total Nucleic Acid Assay
The valid options for the specimen Final result are:
•
•
•
•
•
•

HIV-1 Nucleic Acid Detected
HIV-1 Nucleic Acid Not Detected
Inconclusive
Indeterminate
Invalid
QNS
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• Test Not Performed
Multi-Spot assay
The following result fields must be completed for each Multi-Spot assay
specimen:
•
•
•
•

Control
HIV-1 Peptide
HIV-1 Recombinant
HIV-2 Peptide

The valid options for each of these fields are Reactive or Non-reactive (or
null if the Final result for the specimen is Invalid, QNS, or Test Not
Performed).
The valid options for the Final result are:
•
•
•
•
•
•
•

Non-reactive
Reactive, HIV-1
Reactive, HIV-2
Reactive, HIV-1/2
Invalid
QNS
Test Not Performed

Open discretionary assay
The open discretionary assay is not part of any workflows. It can only be
assigned as a discretionary assay. It is intended for scenarios when the
laboratory needs to provide results for a discretionary assay not already
defined in HAWS.
You must provide the following information about the assay.

Frontier Science Foundation

39

LS.0007 | HAWS User Manual
Field

Options

Final Result

HIV-1 Antibody Reactive/Positive
HIV-1 Antibody Non-reactive/Negative
HIV-2 Antibody Reactive/Positive
HIV-2 Antibody Non-reactive/Negative
HIV Antibody Reactive/Positive
HIV Antibody Non-reactive/Negative
HIV-1 Antigen Reactive/Detected
HIV-1 Antigen Non-reactive/Not Detected
HIV Antibody and Antigen Reactive/
Detected
HIV Antibody and Antigen Non-reactive/Not
Detected
Reactive/Positive/Detected
Non-reactive/Negative/Not Detected
HIV-1 Nucleic Acid Detected
HIV-1 Nucleic Acid Not Detected
HIV-2 Nucleic Acid Detected
HIV-2 Nucleic Acid Not Detected
Equivocal
QNS
Invalid
Inhibited
Inconclusive
Indeterminate
Non-specific
Test Not Performed
Other

Assay Name

Enter the name of the assay

Analyte

HIV-1 Antibody
HIV-2 Antibody
HIV-1 and HIV-2 Antibody
HIV-1 Antigen
HIV Antibody and Antigen
HIV-1 RNA
HIV-1 DNA
HIV-1 RNA and DNA (TNA)
HIV-2 RNA
HIV-2 DNA
HIV-2 RNA and DNA (TNA)
Other

Related tasks
Adding a discretionary test to a workflow on page 48
RNA PCR assay
There are two result fields that must be completed for this assay:
qualifier

This is the operand for the Copies/mL. By default, this
field is set to =. If the reader device detected copies
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outside of its range of quantification, you would need to
change this to reflect the range.
copies/mL

Must be a non-negative integer. Can only be left
blank if the Final result for the specimen is Invalid,
Inhibited, QNS, or Test Not Performed.

The valid options for the final test result are:
•
•
•
•
•
•
•
•

HIV-1 RNA Detected
Not Detected
QNS
Invalid
Inhibited
Detected Below Limit of Quantitation
Detected Above Limit of Quantitation
Test Not Performed

Western Blot assays
The Western Blot assays have result fields for each blot band. All blot bland
fields will be blank by default. You must select a result for each blot band
unless the Final result is Invalid, QNS, or Test Not Performed.
The following are valid options for the Final result field for Western Blot
assays:
•
•
•
•
•
•
•

Positive
Negative
Indeterminate
QNS
Invalid
Non-Specific
Test Not Performed

Approving assay runs
Prerequisites
Note: To approve results, you must have the user can approve results
permission for your account.
Background
After assay results have been committed by a user entering or importing
them, they must be verified.
Steps
1.
2.
3.

Open the Manage runs task.
Select the assay run that you want to approve.
Click the Enter/review results button.
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The Assay Results window will open.
4.

Select a specimen from the Samples list on the left.
The results for the selected sample will be displayed on the right.
These are the results you are reviewing.
Click the Approve results button.
The specimen results will be approved and the Approve results
button will change to De-approve results.
Repeat for each specimen in the Samples list.
After all specimens have been approved, click the Close button.

5.

6.
7.
Result

The assay run is now considered reviewed and approved. If the run had a
final result of Invalid, the results will not be used by HAWS but the results
will be included in the export file (unless the option to exclude the results
from the export file was enabled).
Once the result has been approved it cannot be modified. If an approved
result needs to be modified, you must first De-approve the result

Associating assay results from another workflow
For assays common to multiple algorithms, HAWS allows you to transfer the
results for the same time point from the assay on one workflow to another
workflow.
To use the results of a previously run assay, click the Use Selected Test
button. If manually completing the Process Assay task is needed, click the
Don't use an existing test button.

Importing assay results from a file
Prerequisites
You can import results from an assay reader device for some assay kits.
Results can be imported from the following kits:
•
•
•
•
•

Bio-Rad Genetic Systems HIV 1/2 Plus O
Bio-Rad GS HIV Combo Ag/Ab EIA
Bio-Rad Genetic Systems rLav
Bio-Rad Geenius HIV ½ Confirmation Assay
Abbott Architect HIV Ag/Ab Combo

Background
Importing assay results from a file allows you to bypass entering the results
manually.
Steps
1.

Open the manage runs task.

Frontier Science Foundation

42

LS.0007 | HAWS User Manual
2.

Select the appropriate run from the Available runs list.

3.

Click the Import results from file button.
A dialog window will open for you to browse to the file to be imported.
Select the file that you want to import.

4.
Result

HAWS will extract all results from the file, and any existing results will be
overwritten.
HAWS will extract the appropriate test data for each sample on the run.

Submit redraw task
Background
Certain combinations of results may cause a redraw task to be assigned for a
workflow. The exact circumstances will vary, depending on the algorithm.
To initiate a redraw request for a specimen:
Steps
1.
2.
3.
4.

5.

6.

Select the submit redraw task from the Common Tasks list.
Select the workflow for which you want to process a redraw request.
Click the Do task button.
Optional: Change the default text in the Summary box.
4.1. Click the Select text... button.
4.2. Select a new template from the Redraw reason list.
4.3. Click the OK button.
4.4. Update the text in the Summary box.
Click the Print redraw report button.
The Blinded HIV-1 Infection Status Report will open in the SAP Crystal
Reports® Report Viewer.
Required: Click the [Print] icon from the Report Viewer toolbar.
Important: You must print the Blinded HIV-1 Infection Status
Report. The workflow will not move on to the receive redraw
task until the report has been printed.

Result
After the Blinded HIV-1 Infection Status Report has been printed, the
workflow will be moved to the receive redraw task.
Related tasks
Adding a discretionary redraw to a workflow on page 49
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Receive redraw task
Background
The receive redraw task is for workflows that have completed the submit
redraw task. After the redraw has occurred, you need to associate the new
visit as a redraw visit for the patient. To do this:
Steps
1.

4.

Open the receive redraw task from the Common Tasks list on the
left.
Select the workflow for which you have a redrawn specimen.
Click the Do task button.
The Select Redraw Visit window will open. This window is similar to
the assign a patient visit to a workflow task. Only visits for the patient
with specimens that have a specimen date on or after the date of the
original specimen being redrawn will be displayed.
Select the visit with the redrawn specimen.

5.

• If the visit was entered in LDMS, it will be listed in the Select
Redraw Visit window.
• If the visit was not entered in LDMS, click the New visit button to
create it.
Click the OK button.

2.
3.

Result
The workflow will be moved to the select sample task, and you can now test
specimens from the redraw visit. You can continue to process the workflow as
normal.
Note: the workflow will only create a select sample task if the
algorithm triggers tests after a redraw and will not be the case after
a discretionary redraw. If this is the case, the user must create
discretionary tests on their own.
Related tasks
Manually selecting samples on page 29
Assigning patient visits to an algorithm on page 24

Result algorithm task
Prerequisites
Note: To complete the result algorithm task, you must have the user
can approve results permission.
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Background
The result algorithm task is used to review and assign a final result to a
workflow. After all specimen testing work has been completed for a workflow,
the workflow will be assigned to the result algorithm task. This is where you
will review the results for specimens tested and select the final result for the
workflow.
Steps
1.
2.

3.

Open the result algorithm task.
Select the workflow for which you want to complete the result
algorithm task .
Note: If you do not see the workflow available, go to the view
all workflows task and ensure that all other necessary tasks
have been completed.
Click the Do task button.
The Algorithm Summary window () will open.
Figure 18: The Algorithm Summary window

(1) view tasks that were completed for the workflow, (2) view and create discretionary tests and redraw
tasks, (3) final result for the workflow, (4) approve workflow final result, (5) review the results for the
selected test, (6) date infection was diagnosed for positive results only, (7) summary comments as will
appear on unblinded reports, (8) tested completed for the workflow, (9) general comments that appear on
HIV status report, (10) internal-only comments that are not exported or shown on reports, (11) blinded
report comments that show only on the blinded report, (12) unblinded report comments that only show on
the unblinded report

4.

Review all of the test results.
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5.

6.

7.

4.1. Select a test on the Results tab.
4.2. Click the Review test result button.
4.3. Click the Close button when you are finished reviewing.
Select a final result for the workflow from the Final result list.
The Proposed result field provides a suggested Final result that
was determined by HAWS.
If the Final result is Infected, specify a Diagnosis date
This is only required if there are infected specimens from multiple
dates. If the infected specimen is from one date, HAWS will
automatically select it for you. For protocols that require adjudication,
you will not be able to complete the Diagnosis date until the
Adjudication Report is generated. This is done by clicking the Report
to Adjudicator button that will appear next to the Diagnosis date.
For algorithms that have an unblinded result, select the Unblinded
result [summary text].
The following algorithms have an unblinded result:
•
•
•
•
•

8.

HVTN Evaluation of Sero-Reactivity
Post-Study
Post-Study Testing Service
Confirmation Testing Service
Follow-Up Testing Service

HAWS will automatically select text for you. You can select a different
summary text template by clicking the Select text... button.
Enter comments into the following Comment text boxes:
• General comments: the text you enter here will appear on the HIV
status final report
• Internal-only comments: the text you enter here will not be
exported or appear on reports
• Blinded report comments: The text you enter here will show only
on the blinded report
• Unblinded report comments: the text you enter here will show only
on the unblinded report
Note: If you change the Final result for a workflow for which
a final workflow report has already been printed, you must
enter a comment to explain why the result was changed.

9.
10.

Click the Approve result button.
Click the Close button.

Result
The completed workflow will be assigned the final report task.
Related tasks
Cancelling an algorithm for a workflow on page 51
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Final report task
Background
After a workflow has completed the result algorithm task, it will be assigned
the final report task. For this task, you will generate the final workflow report.
Tip: You can print the final reports for several workflows at once from
the Reports menu.
Steps
1.
2.
3.

4.

Open the final report task.
Select the workflow for which you will be generating a report.
Click the Do task button.
The SAP Crystal Reports® Report Viewer window will open with the
HIV Infection Status Report.
Click the Print button from the Report Viewer toolbar.
Note: The final report task for the workflow will not be
completed until the report is printed.

Related tasks
Batch printing final reports on page 54

Workflow management
View all workflows
The view all workflows task allows you to see all active (and inactive)
workflow on one screen, as well as each workflow's currently assigned task.
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Figure 19: The view all workflows task

(1) filter workflows that are displayed, (2) next task to be completed for the workflow, (3) workflows meeting filter
criteria, (4) view or approve selected workflow, (5) generate (or re-generate) final workflow report, (6) add a new
discretionary test to the selected workflow, (7) add a new discretionary redraw to the selected workflow, (8) complete
the next task for the selected workflow

Almost all of your work in HAWS can be completed from this screen. It is also
very useful for keeping track of open workflows. From this screen you can do
the following:
• Execute the next task in a workflow
• Review previous tasks, assay run results, and the HIV Infection Status
Report
• Add discretionary tests and discretionary redraws
• Modify the export status of a workflow.

Discretionary tests and redraws
Adding a discretionary test to a workflow
Background
In addition to the tests automatically generated by HAWS, you can add
3

discretionary tests to any active workflow. Discretionary tests are processed
just like tests assigned by an algorithm. The workflow will be assigned the
select sample task and process assay task to complete the discretionary test.
The results from discretionary tests will appear in the Algorithm Summary
window with other test results and will appear on the workflow's final report.
Discretionary tests will also be exported to SCHARP (unless explicitly excluded

3

You cannot add discretionary tests to workflows using the Infected or
Retrospective algorithms.
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by the user). Discretionary tests will not be used, however, in the automated
determination of a proposed final algorithm result.
Steps
1.
2.
3.
4.
5.
6.

Open the view all workflows task.
Select the workflow for which you want to add a discretionary test.
Click the Add discretionary test... button.
The Start Discretionary Test window will open.
Select an assay from the Available assay types list.
Optional: Modify the Assay name box.
Click the OK button.

Result
The discretionary test will now be added to the workflow and can be
completed like any other assay in a workflow. You can see what discretionary
tests have been assigned to a workflow on the Algorithm Summary window,
accessed by selecting the workflow in the view all workflows task, and then
clicking the Details button.
Related concepts
Open discretionary assay on page 39

Adding a discretionary redraw to a workflow
Background
A discretionary redraw allows you to manually add a submit redraw task to a
workflow. This can be done for the following algorithms:
•
•
•
•

Routine (VST) (and Routine Vaccine or mAb)
Evaluation of Sero-Reactivity (EOS)
Post-Study (POS)
Recent Exposure/Acute Infection (EXP) (and Recent Exposure/Acute
Infection Vaccine or mAb)

After a new visit has been selected, it becomes the current visit for the
workflow, provided that it is the most recent visit. Any new discretionary tests
and select sample taskswill be associated with the redraw visit.
Redraw visits will be included on the workflow's final report.
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Steps
1.
2.
3.

Open the view all workflows task.
Select the workflow for which you want to add a discretionary visit
from the Workflows list.
Click the Add discretionary redraw... button.
Note: If the Add discretionary redraw... button is disabled,
the workflow may have an algorithm that does not allow
discretionary visits.

4.

5.

6.

The Start Discretionary Redraw window will open.
Select the desired reason for requesting the redraw the from the
Redraw reason list.
The redraw reasons available will vary, depending on the workflow's
algorithm. You will be able to change the text of the redraw reason
prior to generating the redraw request report.
Check the box at the bottom of the window if automatically adding
EIA, RNA PCR, and Geenius tests after the redraw is received is
needed.
Click the OK button.

Result
The workflow will be assigned a submit redraw task. Complete the submit
redraw task as normal.
Related tasks
Submit redraw task on page 43
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Cancelling discretionary tests and redraws
Background
Discretionary tests and redraws can be removed from a workflow if they
should not be completed or were added in error.
Steps
1.
2.
3.
4.

5.
6.

Open the view all workflows task.
Select the workflow for which you want to remove a discretionary visit
or redraw.
Click the Details... button.
The Algorithm Summary window appears.
Change to the Discretionary actions tab.
This tab shows all discretionary tests and discretionary redraws that
have been added to a workflow.
Select the discretionary test or redraw to be removed.
Click the Delete button.

Cancelling an algorithm for a workflow
Background
Cancelling an algorithm for a workflow means that you want to depart from
the normal steps in the workflow's algorithm. You will still be able to perform
discretionary tests and redraws. You will also still be able to set the final
result for the workflow and complete the final report task.
Cancelling an algorithm differs from closing a workflow. Cancelling an
algorithm interrupts the algorithm for the workflow, but still allows you to
generate a final report for the workflow. Closing a workflow ends the workflow
without the option to generate a final report.
Steps
1.
2.
3.

Open the view all workflows task.
Select the workflow you want to cancel from the Workflows list.
Click the Details button.
The Algorithm Summary window will appear.

4.

Click the Cancel automated algorithm button.
You will be asked to confirm that you want to end the algorithm for
the selected workflow.

Result
Any discretionary tests or redraws assigned to the workflow must still be
completed. Once there are no pending discretionary tasks, the cancelled
workflow will be assigned the result algorithm workflow task.
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Related tasks
Result algorithm task on page 44

Closing a workflow
Background
You can close any workflow that has not completed the result algorithm task.
You may need to close a workflow because it was created in error or because
it was created using the wrong algorithm. Closing a workflow will cancel any
pending tasks for the algorithm (discretionary tasks will remain). You will not
be permitted to set a final result or print a final workflow report.

!

Warning: Closing a workflow will automatically apply the Do Not
Export and Do Not Report options to the workflow.

Steps
1.
2.
3.

Open the view all workflows task.
Select the workflow that you want to close from the Workflows list.
The Algorithm Summary window will open.
Click the Close algorithm button.

Available reports
HAWS has several reports that are useful for managing your laboratory's
workflows and productivity.
To generate these reports, click Reports > [Report name] from the HAWS
menu bar. For some reports, you may be asked to supply some information
prior to generating the report, such as a date range.
The following reports are available:
Crashed
Workflows

The Crashed Workflows report lists which workflows
have crashed. The user may use this to verify if a new
workflow was initiated as a replacement.

Pending
algorithms

The Pending algorithms report shows all workflow tasks
that are in progress and not yet completed. Tasks are
grouped by workflow.

Pending redraw The Pending redraw samples report lists all pending
samples
receive redraw tasks (that is, specimens for which a
submit redraw task has been completed and the report
printed).
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Protocol/visit
type summary

The Protocol/visit type summary report lists the
workflows that have been started or completed for each
patient.

Tests per
algorithm

The Tests per algorithm report lists the number of runs
for assay kits. The report is grouped by both kit and by
algorithm, and distinguishes between initial visits and
redraws.

Turn around
time >= X days

The Turn around time >= X days report shows workflows
with a turn around time of greater than or equal to X
days, where X is a number of days specified by the user.

Turn around
time details

View turn around time details.

Turn around
time nonexported

The Turn around time non-exported report shows
workflows that have not yet been exported.

Turn around
time summary

The Turn around time summary report shows the turn
around time difference in days from each event to
the next event for each workflow. Weekend days are
excluded from the calculation as well as any holidays
that were entered within Holiday Administration. The
Turn Around Time Summary Report is broken down into
percentile ranks. Each rank ignores a certain percentage
of the events for that workflow to show the average and
maximum for the remainder. The following percentages
are included:
average/
maximum
(100)

Shows the averages and maximums for
all events

average/
maximum
(95)

Shows the averages and maximums with
the bottom 5% (slowest) events of each
type excluded

Turn around
time with
redraws only

The Turn around time with redraws only report shows
workflows that included at least one redraw.

Visits per
algorithm

The Visits per algorithm report lists the number of visits
for algorithms within a date range specified by the
user. The report distinguishes between initial visits and
redraws.
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Batch printing final reports
Prerequisites
Note: Only users with the Can print reports privilege can batch print
reports.
Background
HAWS can print the final reports for multiple workflows at once. This feature
can be used to save time by printing multiple reports at once. The reports will
be saved automatically in PDF format and printed without needing to open
SAP Crystal Reports® Report Viewer.

!

Warning: Using this feature will automatically print the selected
reports to your default printer. If you need to specify the printer to use,
you must change the default printer in your Windows® Control Panel.

Steps
1.
2.
3.
4.

5.

Click Reports > Batch-print reports... from the HAWS menu bar.
The Print Reports window will open.
Optional: If you want to print reports that have already been printed,
select the Include already created reports option.
Select the report(s) to print.
To select multiple reports, hold down the Ctrl or Shift key.
Optional: Click the Print list.
This will display a list of the reports that will be printed. You can print
this list for review, if needed.
Click the Print reports button.

Result
The reports will be printed from your computer's default printer. PDF files for
each report will also be generated and saved to your computer. They will be in
the Reports folders. There will be a directory in the Reports folder for each
clinic. Within each clinics folder will be the PDF report.
The default location for reports can be modified in the Options window.
Related concepts
Options window on page 11
Related tasks
Final report task on page 47
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Creating unblinded EOS reports
Prerequisites
Note: Only users with the Can print reports privilege can batch print
reports.
Background
Prior to a protocol being unblinded, SCHARP receives unblinded EOS reports.
SCHARP will request that the laboratory send unblinded EOS reports for all
patients on a specific protocol, or they may send the laboratory a text file
containing a list of patients whose unblinded EOS reports should be sent.
Steps
1.

2.

3.
4.
5.

Click Reports > Create unblinded EOS reports for SCHARP from
the HAWS menu bar.
The Create Unblinded Reports for SCHARP window will appear.
Do one of the following:
• If SCHARP provided your laboratory with a protocol number, enter
the protocol into the Create reports for all algorithms for this
protocol box.
• If SCHARP provided your laboratory with a text file listing of
patients, click the Open file button and select the text file.
Optional: If you want to print reports that have already been printed,
select the Include already created reports option.
Select the reports to be printed.
To select multiple reports, hold down the Ctrl or Shift key.
Click the Create reports button.

Result
PDF files for each report will be generated and saved to your computer. They
will be in the Reports folders. There will be a sub-directory in the Reports
folder called Unblinding. Within this directory will be a directory for each
clinic, and within each clinic's folder a PDF of the report.
Figure 20: Unblinding report directory structure
C:\fstrf-haws\Reports\Unblinding\[protocol]\[clinic]\[report].pdf
Figure 21: Report PDF file naming convention
[PatientID]-v[Visit Number]-[Draw Date]rpt[Algorithm]Unblinded.pdf
123456789-v7-24Aug-2009-rptEvaluationofSeroReactivityUnblinded.pdf
The default location for reports can be modified in the Options window.
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Related concepts
Options window on page 11

Export reports
Export reports are tab-delimited text files that are intended to be sent to
SCHARP.
Background
An export file is generated for each protocol and contains test results for all
completed workflows. Results for sub-studies are included in the same export
file as the parent protocol.
Only test results from completed workflows are included in export files.
Results from protocols marked as locked will not be exported, nor will
individual tests or workflows that have been marked as Do not export.
Note: Western Blot tests using the Bio-Rad New Lav Blot II kit will not
be included in export files.
Steps
1.
2.

On the File menu, click Export Results.
When the “Export Results” message appears, click OK.

After you are finished
The export files will be placed in the export base folder.
Note: If any export files were generated again, their filename will be
appended with a number.
Related concepts
Options window on page 11
Related tasks
Running an assay on page 33

Generating adjudication report
Steps
1.
2.
3.
4.
5.

In the tasks list, click View all workflows.
In the Workflows list, select the workflow for which you will be
generating the adjudication report.
Click Details.
(If required), select the result from the Final Result box.
In the Diagnosis box, select the date of the diagnosis.
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6.

Click Report to adjudicator.

Result
The adjudication report will be in the Adjudication folder in the export
directory.
Related tasks
Changing protocol adjudication settings on page 13

Algorithms
This section lists details about the various algorithms that are available in
HAWS.
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Confirmation Algorithm (visit = CFM)
Figure 22: Confirmation algorithm
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Table 1: CFM Algorithm - Blinded and Unblinded Report Summary
Comments
ECR (EIA/
CMIA/
Rapid)

Geenius
HIV-1
(assay
RNA
interpretation)**

1

Nonreactivex3

Not required

2

Reactive x1
or 2 or 3

Negative

3

4

HIV-2
TNA

Unblinded CFM
result summary
text

Not
Not
Not
detected detected required

Not
required

Further testing
required. Draw
a new 10mL
EDTA whole blood
sample using
visit type “Followup” (FUP).

Not
Not
Not
detected detected required

Not
required

Further testing
required. Draw
a new 10mL
EDTA whole blood
sample using
visit type “Followup” (FUP).

Reactive x1
or 2 or 3

Not
Not
Not
HIV1
indeterminate detected detected required
or HIV1
positive

Not
required

Further testing
required. Draw
a new 10mL
EDTA whole blood
sample using
visit type “Followup” (FUP).

Reactive x1
or 2 or 3

Negative, or

Not
required

Not
required

HIV-1 Infected

Reactive x1
or 2 or 3

Negative, or

Not
Detected Not
detected
required

Not
required

HIV-1 Infected

6

Reactive x1
or 2 or 3

HIV2 Positive

Not
Not
detected required

Not
required

HIV-2 Infected

7

Reactive x1
or 2 or 3

HIV PositiveUntypable

Not
Not
Detected Not
HIV-2 Infected
detected detected
detected

8

Reactive x1
or 2 or 3

HIV PositiveUntypable

Not
Not
Not
Detected HIV-2 Infected
detected detected detected

9

Reactive x1
or 2 or 3

HIV PositiveUntypable

Detected Not
required

10

Reactive x1
or 2 or 3

HIV PositiveUntypable

Not
Detected HIV-1 and HIV-2
Detected Not
detected
detected
Infected

5

HIV1
indeterminate,
or HIV1
positive

HIV1
indeterminate,
or HIV1
positive
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HVTN EOS Algorithm (visit = EOS)
Figure 23: HVTN EOS algorithm
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Table 2: EOS Algorithm – Blinded and Unblinded Report Summary
Comments
ECR (EIA/
CMIA/
Rapid)

Geenius
HIV-1
(assay
RNA
interpretation)**

HIV-1
HIV-2
TNA(or RNA
DNA)

HIV-2
TNA

Unblinded EOS
result summary text

1

Non-reactive Not required
x3 + NR
Abbott Prism

Not
Not
Not
Not
No evidence of
required required required required infection with HIV-1
or HIV-2. No evidence
of vaccine-induced
sero-reactivity or
serological crossreactivity.

2

NonNot required
reactive x3
+ Reactive
Abbott Prism

Not
Not
Not
Not
No evidence of
required required required required infection with HIV-1
or HIV-2. No evidence
of non-specific
sero-reactivity or
vaccine-induced
sero-reactivity (if
participant received
vaccine product)
by most recent
methods available.
Evidence of nonspecific or possible
vaccine-induced
sero-reactivity
by a less specific
method (Abbott Prism
HIV-1/2/O Plus).

3

Reactive x1
or 2 or 3

Negative

Not
Not
Not
Not
No evidence of
Detected Detected required required infection with HIV-1 or
HIV-2. These results
are consistent with
vaccine-induced
sero-reactivity, if
participant received
vaccine product, or
these results may be
due to non-specific
serological crossreactivity.

4

Reactive x1
or 2 or 3

Not
Not
Not
Not
HIV1
indeterminate Detected Detected required required
or HIV1
positive
(consistent
with
product)

Frontier Science Foundation
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5

ECR (EIA/
CMIA/
Rapid)

Geenius
HIV-1
(assay
RNA
interpretation)**

Reactive x1
or 2 or 3

Negative or
HIV1
indeterminate
or HIV1
positive or

HIV-1
HIV-2
TNA(or RNA
DNA)

HIV-2
TNA

Unblinded EOS
result summary text

Detected Not
Not
Not
Infected, HIV-1
required required required

HIV Positive,
Untypable
6

Reactive x1
or 2 or 3

Not
Detected Not
Not
Infected, HIV-1
Negative
detected
required required
or HIV-1
indeterminate
or HIV-1
positive or
HIV Positive,
Untypable

7

Reactive x1
or 2 or 3

HIV2
Positive

8

Reactive x1
or 2 or 3

HIV2
Not
Infected, HIV-2
Not
Detected Not
indeterminate required required
required

9

Reactive x1
or 2 or 3

HIV2
Not
Not
Detected Infected, HIV-2
Not
indeterminate required required detected

10

Reactive x1
or 2 or 3

HIV Positive,
Untypable

Not
Not
Detected Not
Infected, HIV-2
detected detected
detected

11

Reactive x1
or 2 or 3

HIV Positive,
Untypable

Not
Not
Not
Detected Infected, HIV-2
detected detected detected

12

Reactive x1
or 2 or 3

HIV Positive,
Untypable

Infected, HIV-1 and
Detected Not
Detected Not
required
required HIV-2

13

Reactive x1
or 2 or 3

HIV Positive,
Untypable

Not
Detected Infected, HIV-1 and
Detected Not
detected
detected
HIV-2

14

Reactive x1
or 2 or 3

HIV Positive,
Untypable

Not
Detected Infected, HIV-1 and
Detected Not
required detected
HIV-2
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Vaccine Recent Exposure Algorithm (visit = EXP)
Figure 24: Vaccine Recent Exposure Algorithm
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ECR
Criteria

RNA
Criteria

Nonreactive,
Reactive or
Equivocal x1
ECR
Nonreactive,
Reactive or
Equivocal x1
ECR

DNA
Criteria

Pass

Proposed Algorithm Result Summary

Not Detected Not required

1

No evidence of infection with HIV-1.

Detected

1

Further Testing Required. Draw new
sample per protocol requirements and
submit using visit type Redraw

Not required
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mAb Recent Exposure Algorithm (visit = EXP)
Figure 25: mAb Recent Exposure Algorithm
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ECR
Criteria

RNA
Criteria

Geenius
Criteria

Pass

Proposed Algorithm Result Summary

Non-reactive
x1 ECR

Non-reactive
x1 ECR

N/A

1

No evidence of infection with HIV-1 or
HIV-2.

Reactive or
Equivocal 1x
ECR

Any

Any

1

Further Testing Required. Draw new
sample per protocol requirements and
submit using visit type Redraw/RDW

Any

Reactive or
Equivocal 1x
ECR

Any

1

Further Testing Required. Draw new
sample per protocol requirements and
submit using visit type Redraw/RDW
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Follow-up Algorithm (visit = FUP)
Figure 26: Follow-up algorithm
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ECR
Criteria

HIV-1 RNA
Criteria

HIV-1 DNA
Criteria

Pass

Proposed Algorithm Result Summary

Non-reactive
x1

Not detected

Not detected

1

Blinded: No evidence of infection with
HIV-1.
Unblinded Report: No evidence of infection
with HIV-1.
If any previous HVTN HIV diagnostic
test results showed evidence of vaccineinduced sero-reactivity, it is recommended
that HIV diagnostic testing continue
through the HVTN until no evidence of
sero-reactivity is repeatedly demonstrated.

Reactive x1

Not detected

Not detected

1

Blinded: No evidence of infection with
HIV-1.
Unblinded: No evidence of infection with
HIV-1. These results may be due to
vaccine-induced sero-reactivity (VISR) or
non-specific cross-reactivity.

Reactive x1

Not detected

Positive

1

Blinded or Unblinded: HIV-1 Infected
based on FUP and SRV or CFM lab results.

Reactive x1

Positive

Positive

1

Blinded or Unblinded: HIV-1 Infected
based on FUP and SRV or CFM lab results.

Infected Testing Algorithm (visit = INF)
Figure 27: Infected testing algorithm
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Post-study Algorithm (visit = POS)
Figure 28: Post-study (POS) algorithm

Post-study Algorithm

Start

EIA 1

EIA 2

EIA 3

Condionally
Trigger
Geenius

Condionally
Trigger
Geenius

Condionally
Trigger
Geenius

RNA PCR

N

N

Propose result:
Uninfected, HIV-1
+ HIV-2,
No VISP

Any EIA
Reacve?

Posive?

Y

Y

Redraw

Propose result:
Uninfected, HIV-1
+ HIV-2,
Likely VISP

EIA
(redraw)

RNA
(redraw)

Geenius
(redraw)

Propose result:
None

End

Frontier Science Foundation

69

LS.0007 | HAWS User Manual
Table 3: POS Algorithm – Blinded and Unblinded Report Summary
Comments
ECR (EIA/
CMIA/
Rapid)

Geenius
HIV-1
(assay
RNA
interpretation)**

HIV-1
TNA
(or
DNA)

HIV-2
RNA

HIV-2
TNA

Unblinded POS result
summary text

1

Nonreactive
x3 + NR
Abbott
Prism

Not
required

Not
Not
Not
Not
No evidence of infection
detected required required required with HIV-1 or HIV-2.
No evidence of vaccineinduced sero-reactivity or
non-specific serological
cross-reactivity. If
any previous HVTN
HIV diagnostic test
results showed evidence
of vaccine-induced
sero-reactivity, it is
recommended that
HIV diagnostic testing
continue through the
HVTN until no evidence
of sero-reactivity is
repeatedly demonstrated.

2

Nonreactive x3
+ Reactive
Abbott
Prism

Not
required

Not

3

Reactive x1
or 2 or 3

Negative

Not
Not
Not
Not
No evidence of infection
Detected detected required required with HIV-1 or HIV-2.
These results are
consistent with vaccineinduced sero-reactivity,
if participant received
vaccine product, or these
results may be due to
non-specific serological
cross-reactivity.

Not
Not
Not
No evidence of infection
required required required with HIV-1 or HIV-2. No
detected
evidence of non-specific
sero-reactivity or vaccineinduced sero-reactivity
(if participant received
vaccine product) by most
recent methods available.
Evidence of non-specific
or possible vaccineinduced sero-reactivity
by a less specific method
(Abbott Prism HIV-1/2/O
Plus).
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4

ECR (EIA/
CMIA/
Rapid)

Geenius
HIV-1
(assay
RNA
interpretation)**

Reactive x1
or 2 or 3

Not
Not
Not
Not
HIV1
indeterminate Detected detected required required
or HIV1
positive
(consistent
with
product)

5

Reactive x1
or 2 or 3

Negative or
HIV1
indeterminate
or HIV1
positive or

HIV-1
TNA
(or
DNA)

HIV-2
RNA

HIV-2
TNA

Unblinded POS result
summary text

No evidence of infection
with HIV-1 or HIV-2.
These results are
consistent with vaccineinduced sero-reactivity,
if participant received
vaccine product, or these
results may be due to
non-specific serological
cross-reactivity.

Detected Not
Not
Not
Infected, HIV-1
required required required

HIV
Positive,
Untypable
6

Reactive x1
or 2 or 3

Not
Detected Not
Not
Infected, HIV-1
Negative
detected
required required
or HIV-1
indeterminate
or HIV-1
positive or
HIV
Positive,
Untypable

7a

Reactive x1
or 2 or 3

HIV2
Positive

Not
Not
Infected, HIV-2
Detected Not
detected required
required

7b

Reactive x1
or 2 or 3

HIV2
Positive

Not
Not
Not
Detected Infected, HIV-2
detected required detected

8a

Reactive x1
or 2 or 3

HIV2
Not
Infected, HIV-2
Not
Detected Not
indeterminate detected required
required

8b

Reactive x1
or 2 or 3

HIV2
Not
Not
Detected Infected, HIV-2
Not
indeterminate detected required detected

9a

Reactive x1
or 2 or 3

HIV
Positive,
Untypable

Not
Not
Detected Not
Infected, HIV-2
detected detected
detected

9b

Reactive x1
or 2 or 3

HIV
Positive,
Untypable

Not
Not
Not
Detected Infected, HIV-2
detected detected detected

10a Reactive x1
or 2 or 3

HIV
Positive,
Untypable

Infected, HIV-1 and
Detected Not
Detected Not
required
required HIV-2
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ECR (EIA/
CMIA/
Rapid)
10b Reactive x1
or 2 or 3

Geenius
HIV-1
(assay
RNA
interpretation)**
HIV
Positive,
Untypable

HIV-1
TNA
(or
DNA)

HIV-2
RNA

HIV-2
TNA

Unblinded POS result
summary text

Not
Detected Infected, HIV-1 and
Detected Not
detected
detected
HIV-2

Retrospective Algorithm (visit = RRV)
Figure 29: Retrospective (RRV) algorithm
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Post-study Testing Service Algorithm (visit =
SRV)
Figure 30: Post study testing service (SRV) algorithm

Post-study Tesng Service
Start

EIA 1

EIA 2

EIA 3

Condionally
Trigger
Geenius

Condionally
Trigger
Geenius

Condionally
Trigger
Geenius

N

N

Is any EIA
Reacve?

Propose result:
Uninfected,
No VISP

Is RNA Posive?

RNA

Y

Y

Propose result:
Presumpve
Infected

Propose result:
Uninfected,
Likely VISP

End
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Table 4: SRV Algorithm - Blinded and Unblinded Report Summary
Comments

1

ECR (EIA/
CMIA/
Rapid)

Geenius
HIV-1
(assay
RNA
interpretation)**

Nonreactivex3

Not
required

Not
Not
Not
Not
No evidence of infection
detected
required required with HIV-1 or HIV-2.
required
No evidence of vaccineinduced sero-reactivity or
non-specific serological
cross-reactivity. If
any previous HVTN
HIV diagnostic test
results showed evidence
of vaccine-induced
sero-reactivity, it is
recommended that
HIV diagnostic testing
continue through the
HVTN until no evidence
of sero-reactivity is
repeatedly demonstrated.

Not
required

Not

Negative

Not
Not
Not
Not
No evidence of infection
Detected detected required required with HIV-1 or HIV-2.
These results are
consistent with vaccineinduced sero-reactivity,
if participant received
vaccine product, or these
results may be due to
non-specific serological
cross-reactivity.

+ NR
Abbott
Prism

2

Nonreactivex3
+ Reactive
Abbott
Prism

3a Reactive x1
PrEP or 2 or 3
yes

HIV-1
TNA
(or
DNA)

HIV-2
RNA

HIV-2
TNA

Unblinded SRV result
summary text

Not
Not
No evidence of infection
required required with HIV-1 or HIV-2. No
detected required
evidence of non-specific
sero-reactivity or vaccineinduced sero-reactivity
(if participant received
vaccine product) by most
recent methods available.
Evidence of non-specific
or possible vaccineinduced sero-reactivity
by a less specific method
(Abbott Prism HIV-1/2/O
Plus).
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ECR (EIA/
CMIA/
Rapid)

Geenius
HIV-1
(assay
RNA
interpretation)**

Reactive x1
or 2 or 3

Negative

4

Reactive x1
or 2 or 3

Not
Not
Not
Not
HIV1
indeterminate Detected detected required required
or HIV1
positive

No evidence of infection
with HIV-1 or HIV-2.
These results are
consistent with vaccineinduced sero-reactivity,
if participant received
vaccine product, or these
results may be due to
non-specific serological
cross-reactivity.

5

Reactive x1
or 2 or 3

Not
Not
Negative, or Detected Not
required required required
HIV1
indeterminate,
or HIV1
positive

Presumptive HIV-1
Infected, based on a
single blood specimen.
Recommend further
testing for confirmation.
Please draw a new
sample per service
testing requirements and
submit using visit type
“Confirmation/CFM”.

6

Reactive x1
or 2 or 3

Detected Not
Not
Negative, or Not
Detected
required required
HIV1
indeterminate,
or HIV1
positive

Presumptive HIV-1
Infected, based on a
single blood specimen.
Recommend further
testing for confirmation.
Please draw a new
sample per service
testing requirements and
submit using visit type
“Confirmation/CFM”.

7

Reactive x1
or 2 or 3

HIV2
Positive

3b
PrEP
no

HIV-1
TNA
(or
DNA)

HIV-2
RNA

HIV-2
TNA

Unblinded SRV result
summary text

Not
Not
Not
Not
No evidence of infection
Detected required required required with HIV-1 or HIV-2.
These results are
consistent with vaccineinduced sero-reactivity,
if participant received
vaccine product, or these
results may be due to
non-specific serological
cross-reactivity.

Not
Not
Not
Not
Presumptive HIV-2
detected required required required Infected, based on a
single blood specimen.
Recommend further
testing for confirmation.
Please draw a new
sample per service
testing requirements and
submit using visit type
“Confirmation/CFM”.
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ECR (EIA/
CMIA/
Rapid)

Geenius
HIV-1
(assay
RNA
interpretation)**

8

Reactive x1
or 2 or 3

HIV
PositiveUntypable

Not
Not
Detected Not
Presumptive HIV-2
detected detected
detected Infected, based on a
single blood specimen.
Recommend further
testing for confirmation.
Please draw a new
sample per service
testing requirements and
submit using visit type
“Confirmation/CFM”.

9

Reactive x1
or 2 or 3

HIV
PositiveUntypable

Not
Not
Not
Detected Presumptive HIV-2
detected detected detected
Infected, based on a
single blood specimen.
Recommend further
testing for confirmation.
Please draw a new
sample per service
testing requirements and
submit using visit type
“Confirmation/CFM”.

10

Reactive x1
or 2 or 3

HIV
PositiveUntypable

Presumptive HIV-1 and
Detected Not
Detected Not
required
required HIV-2 Infected, based on
a single blood specimen.
Recommend further
testing for confirmation.
Please draw a new
sample per service
testing requirements and
submit using visit type
“Confirmation/CFM”.

11

Reactive x1
or 2 or 3

HIV
PositiveUntypable

Not
Detected Presumptive HIV-1 and
Detected Not
detected
detected
HIV-2 Infected, based on
a single blood specimen.
Recommend further
testing for confirmation.
Please draw a new
sample per service
testing requirements and
submit using visit type
“Confirmation/CFM”.
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TNA
(or
DNA)

HIV-2
RNA

HIV-2
TNA

Unblinded SRV result
summary text
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Vaccine Routine algorithm (visit = VST)
Figure 31: Vaccine Routine algorithm

Vaccine Roune

Start

EIA
(inial)

Reacve?

Y

RNA PCR

N

Propose result:
Uninfected

Posive?

Y

Redraw

N

Geenius

End
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EIA
(redraw)

RNA
(redraw)

Geenius
(redraw)

Propose result:
None
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ECR
Criteria

RNA
Criteria

DNA
Criteria

Pass

Non-reactive
x1 ECR

Not Required

Not Required

1

Reactive or
Equivocal x1
ECR

Not Detected Not Required

1

Reactive or
Equivocal x1
ECR

Detected

1

Not Required

Frontier Science Foundation

Proposed Algorithm Result Summary

No evidence of infection with HIV-1.

No evidence of infection with HIV-1.
Further Testing Required. Draw new
sample per protocol requirements and
submit using visit type “Redraw/RDW"
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mAb Routine Algorithm (visit = VST)
Figure 32: mAb Routine algorithm

mAb Roune

Start

EIA
(inial)

Reacve?

Y

N

Propose result:
Uninfected

RNA
(inial)

Redraw

EIA
(redraw)

RNA
(redraw)

Geenius
(redraw)

Propose result:
None

End
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ECR
Criteria

RNA
Criteria

DNA
Criteria

Pass

Proposed Algorithm Result Summary

Non-reactive
x1 ECR

Not required

Not required

1

No evidence of infection with HIV-1 or
HIV-2.

Reactive or
Equivocal 1x
ECR

Not required

Not required

1

Further Testing Required. Draw new
sample per protocol requirements and
submit using visit type Redraw/RDW

Minimal Post-Study Algorithm
Figure 33: Minimal Post-Study Algorithm

Minimal Post-Study
Start

Perform 4th/5th Gen
HIV Ag/Ab Combo

Perform HIV-1
RNA Assay

Reacve?

HIV-1 Result

Yes

Await the result from
the 4th/5th Gen HIV
Ag/Ab Combo test

Perform Geenius
HIV-1/2
Diﬀerenaon Test

HIV-1 RESULT if RNA
Negave*

+

No

HIV-2 RESULT if RNA
Negave:

Request Redraw

Community test #1

Community test #2

Yes

Yes

y/n

+

Likely VISP

Contact HVTN Lab
Support for guidance

Perform HIV-2 RNA
PCR

Frontier Science Foundation

REPORT AS NO
EVIDENCE OF HIV-1 or
HIV-2; NO FURTHER
ACTION REQUIRED

Likely VISP
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Criteria

Result

RNA is Detected

Standard redraw is triggered (SubmitRedraw,
ReceiveRedraw, EIA, Geenius, RNA PCR)

EIA is Reactive

Geenius is triggered*

EIA is Non-reactive

EIA 2 and EIA 3 tests are triggered

RNA was positive and a redraw was triggered

HAWS will propose no result

All EIAs were non-reactive

HAWS will propose Uninfected with no
evidence of VISP

At least one EIA was reactive

HAWS will propose Uninfected, likely VISP

*Geenius results are not used in determining the final proposed result, but
may indicate to the lab to run a discretionary HIV-2 test (not supported in
HAWS)

Glossary of terms
final report task
Task for generating the final workflow report after a workflow is completed.
Also known as: Report
process assay task
Workflow task for entering assay results
Also known as: ProcessAssay
receive redraw task
Process a specimen that has been redrawn by selecting the specimen from a
new visit.
reassign specimen for a test
Change the specimen assigned to be tested on an assay.
Also known as: ResultAlgorithm
review assay task
Workflow task for reviewing and approving assay runs
select sample task
Workflow task for selecting the specimen to be tested.
Also known as: SelectSample
submit redraw task
Workflow task for initiating the redraw of a specimen, such as when the final
result is QNS.
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Revision history
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Version

HAWS
Version

Date
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-

6.3.0
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Updated "Location Administration" section

-

6.2.0

2020-11-07

Updated "Backup Management" section;
updated "Supported Assays" section to include
"SD Bioline EIA test" kit and "Determine HIV
Early Detect" Alere kit

-

6.1.0
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Added option to "Adding a Discretionary
Redraw to a Workflow" section about whether
the ECR/Geenius/RNA PCR tests should be
automatically created

-

6.0.0
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Clinic UI screen updated; added "alere HIV
Combo" as new kit; algorithm diagrams and
charts updated

-

5.5.0

2019-03-12

Removed erroneously included section; fixed
algorithm descriptions

-

5.5.0
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Updated remainder of algorithms to newer
style; Updated available reports and assays
sections

-
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HAWS 5.4 updates
•
•
•
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for AMP protocols
Redraw algorithm phase for AMP protocols

-
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HAWS 5.3 updates

-
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-

5.1

2017-05-31

HAWS 5.1 updates

-
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